StoneBlock server setup

Discussion in 'Community Support' started by Sedastian, Oct 9, 2021.

  1. Sedastian

    Sedastian New Member

    Joined:
    Jan 5, 2020
    Messages:
    2
    Likes Received:
    0
    I downloaded the StoneBlock modpack and put it into my server. However, I cannot get it working through hosthorde. I have the .jar set up correctly with the libraries folder in the jar folder. Changed the forge.jar to custom_server.jar as expected (and usual).

    I've ran multiple different modpacks on my hosthorde server over the years and have not had this problem.

    Here is what the console tells me, it literally takes a second for it to happen. I've tried using the 8Launcher.jar as well, and it gets farther in, but still does not work.

    Any help is appreciated.

    08.10 23:19:03 [Multicraft] Server stopped
    08.10 23:19:03 [Multicraft] Received stop command
    08.10 23:18:57 [Server] INFO /run.sh: line 38: 29412 Killed /disk2/multicraft/monitor.sh "$PID" "$USER"
    08.10 23:18:56 [Server] INFO ... 6 more
    08.10 23:18:56 [Server] INFO at net.minecraft.launchwrapper.Launch.main(Launch.java:28)
    08.10 23:18:56 [Server] INFO at net.minecraft.launchwrapper.Launch.<init>(Launch.java:34)
    08.10 23:18:56 [Server] INFO Caused by: java.lang.ClassCastException: class jdk.internal.loader.ClassLoaders$AppClassLoader cannot be cast to class java.net.URLClassLoader (jdk.internal.loader.ClassLoaders$AppClassLoader and java.net.URLClassLoader are in module java.base of loader 'bootstrap')
    08.10 23:18:56 [Server] INFO at net.minecraftforge.fml.relauncher.ServerLaunchWrapper.main(ServerLaunchWrapper.java:34)
    08.10 23:18:56 [Server] INFO at net.minecraftforge.fml.relauncher.ServerLaunchWrapper.run(ServerLaunchWrapper.java:70)
    08.10 23:18:56 [Server] INFO at java.base/java.lang.reflect.Method.invoke(Method.java:566)
    08.10 23:18:56 [Server] INFO at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    08.10 23:18:56 [Server] INFO at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    08.10 23:18:56 [Server] INFO at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    08.10 23:18:56 [Server] INFO A problem occurred running the Server launcher.java.lang.reflect.InvocationTargetException
    08.10 23:18:55 [Server] INFO $START
    08.10 23:18:55 [Multicraft] Loaded config for "Mod: Custom Server"
    08.10 23:18:55 [Multicraft] Starting server!
    08.10 23:18:55 [Multicraft] Loading server properties
    08.10 23:18:55 [Multicraft] Received start command
    08.10 23:18:52 [Multicraft] Loading server properties
     
  2. Sedastian

    Sedastian New Member

    Joined:
    Jan 5, 2020
    Messages:
    2
    Likes Received:
    0
    So apparently, the server failed to download the /jre8 folder and accompanying files when the 8launcher.jar was installed and ran. I tried to run FTB StoneBlock2 and it pulled these files in. When I noticed that, I went back to the original stoneblock and it works now.

    So, make sure that the /jre8 folder and files are in your directory as well! They don't go into the /jar folder, they're in the root directory.
     

Share This Page

  • About Us

    HostHorde is the industry first as an unlimited Minecraft server provider. We provide premium Minecraft hosting, with unbeatable performance and quality support.

    Our forums enable you to ask questions, solve problems, find information, and share resources with other members of the HostHorde community.

    View Our Plans
  • Social Media